Payload Studio
Search…
⌃K

Getting Started

Understanding the basics of the PayloadStudio interface

TL;DR Overview

PayloadStudio Overview
Upon logging in for the first time PayloadStudio will take you on a tour; you can relaunch the tour under Help > Product Tour at any time for a refresher!
Help > Product Tour
Access various features and settings of PayloadStudio. Clicking one will toggle the menu open/closed.
PayloadStudio Menu bar (Top Left)

File Menu

File menu from the Menu Bar

Import or Open Payloads

Don't know where to start on your payload writing journey? Open Examples, import via URL or even upload from local files directly into the editor!
Open / Import payload modal

Resources

Links directly to relevant repositories, Hak5 PayloadHub, Shop and Community.
PayloadStudio Resources (Top Right)

Payload Editor

Here you can craft your payloads for all your favorite Hak5 gear. We've got it all set up for you with everything from autocompletion to syntax highlighting and more. Where you'll spend most of your time in PayloadStudio!
Remember: you can customize your experience in the Settings!
PayloadStudio Payload Editor

Compile / Deploy

Compile your DuckyScript payloads, or, for other device modes, save your payload.
PayloadStudio Generate Payload / Save Payload button
Read More about devices and deploying payloads

Console

PayloadStudio will use this as a location to tell you important info. It's also used for DuckyScript Debugging/Breakpoints. Errors, messages, and status updates will appear here. Hide the console to keep it out of the way while building your payload or open it for an easy notepad-like environment to test your keystroke injection in! No more juggling multiple windows!
The console can be used to test parts of your payload, it's also a convenient text editor with the ability to Edit, Save, Clear, and toggle Open with ease.
PayloadStudio Console

Open the Console

Console toggle button (Bottom Right)
Open the Console button

Minimize the console

Minimize the console button
ESC / Escape will also minimize the console if it is open in the default keybinding mode

Help menu

Here you can find links to more detailed documentation (here
👋
) as well as other useful info
  • Documentation
  • Quick Reference
  • Relaunch Product Tour

Session Status bar

The session status bar provides at a glance info regarding your payload editing session as well as shortcuts to common actions.
Session Status bar

Info, warning and error counts

Info, warning and error counts are only used in USB Rubber Ducky mode
Info, warning and error counts
Clicking one of the Info, warning and error indicators will step through them in your editor

Current DUCKY_LANG

DUCKY_LANG is only used in USB Rubber Ducky mode
Info, warning and error counts
Clicking the language by default will bring you to Compiler Settings to change your DUCKY_LANG

Editing / Read Only mode indicator and toggle

Toggle editor from Read Only to Editing by clicking the label or icon pinned to the top right above the editor
Read Only Mode
Editing Mode

Session Save Status

Auto save status is indicated at the top right of the editor
Unsaved Session Indicator
Unsaved
Saved Session Indicator
Saved
Change Editor Modes by clicking the device name or logo, and view + edit your current payload filename
Breadcrumbs

Payload Name

Ready to export your payload source code? Naming it will help keep you organized. Change the name of your payload by double clicking the current payload name from the top left of the editor.
Edit payload name

Device / Editing mode

Changing editor modes is as easy as two clicks!
  1. 1.
    Click the current device from the top left of the editor
  2. 2.
    Choose a new device mode from the Device Picker Menu
Change editor mode
PayloadStudio Device Picker
Read More about devices and deploying payloads